Back to overview
Downtime
Complete downtime
May 22 at 07:32am CEST
Affected services
Woffu
Clock In
API
Reports
Documents
Notifications
Home
Importer
Integrations
Woffu
Resolved
May 22 at 08:14am CEST
We’re back! Woffu should be up and running. Thanks for bearing with us.
Affected services
Created
May 22 at 07:32am CEST
Woffu is down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services